Chapter Two: Sketching, Constraining and Dimensions

Chapter Outline

This is a description of the topics covered in this chapter, including the exercises.

**Topic: How to sketch, constrain and use dimensions**

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Topics</th>
<th>Estimated Time (Hours)</th>
<th># of PowerPoint slides</th>
<th>Recommended</th>
<th>Optional</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Introduce how to sketch, constrain and dimension</td>
<td>1.5</td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Review course objectives for Chapter Two</td>
<td></td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Sketching and part applications options</td>
<td></td>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Units</td>
<td></td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Templates</td>
<td></td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Creating a part</td>
<td></td>
<td>2</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Sketches overview</td>
<td></td>
<td>3</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Exercise 2-1: Creating a sketch with lines</td>
<td></td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Exercise 2-2: Creating a sketch with tangencies</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>2</td>
<td>Constraining the sketch</td>
<td>1.5</td>
<td>3</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Exercise 2-3: Adding and displaying constraints</td>
<td></td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Adding Dimensions</td>
<td></td>
<td>4</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Exercise 2-4: Dimensioning a sketch</td>
<td></td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Summary of the chapter</td>
<td></td>
<td>1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Applying Your Skills: Exercises 2-1, 2-2</td>
<td></td>
<td>1</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>2</td>
<td>Review Checking Your Skills answers at end of chapter</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td><strong>Total Estimated Hours</strong></td>
<td></td>
<td><strong>3</strong></td>
<td><strong>24</strong></td>
<td></td>
</tr>
</tbody>
</table>
Slide 1

Autodesk Inventor 6
Sketching, Constraining, and Dimensioning

Slide 2

Objectives - Sketching, Constraining, and Dimensioning

» Chapter Objectives
  » Sketch and part options
  » Sketching an outline of a part
  » Creating geometric constraints
  » Dimensioning a sketch
  » Changing a dimension’s value in a sketch
TRAINER NOTE

Emphasize that settings on tabs of the Application Options dialog box affect all documents.
Slide 5

TECHNICAL INFORMATION

- Snap to grid: Select this option to sketch geometry by snapping to the grid. Clear this selection to sketch shapes freely without regard to size, and later add and edit dimensions to resize geometry.

- Autoproject edges during curve creation: Selects existing geometry and projects it into the current sketch by “rubbing” the lines. Projected geometry is reference geometry and cannot be edited.

- Automatic reference edges for new sketch: Projects the edges of the selected face into a new sketch. If you do not intend to use the face edges, you may wish to turn this option off to avoid creating unneeded geometry.

- Edit dimension when created: Opens the edit dimension box when you place a dimension. Used together with free sketching (grid snap off), this option lets you add precision while still sketching quickly. Clear this check box to place a dimension without editing. Double-click the dimension value to change it later.
Sketching & Part Application Options

- Part Options
  - Customized your preferences
    - Settings are global
    - Affects all open & new Inventor documents
  - Sketch on New Part Creation
  - Parallel View on Sketch Creation
  - Auto-Hide In-Line Work Features
  - Construction

TECHNICAL NOTES

The part tab sets
- preferences for the default sketch plane in a new part file
- orientation of the sketch view
- behavior of in-line work features after they are used by another work feature
- the appearance of construction surfaces,
TECHNICAL NOTES

Options on the Document Settings tabs affect only the current document.

The Units tab:

- Specifies length, angle, time, and mass units.
- Specifies precision decimal places for linear and angular dimension displays, and the dimension style.
TECHNICAL NOTES
Create templates with your preferred application and document settings so you don’t have to set them every time. Files stored in the template directory are automatically templates.
Slide 10

Sketching, Constraining, and Dimensioning

Creating a Part

Creating a Part
- Standard.ipt icon
- File menu
- Shortcut key
- New icon
- Part environment

Slide 11
Creating a Part

**Sketches & Default Planes**
- Sketch plane
- 2D objects are sketched
- Active sketch
- Three planes
  - XY, YZ, and XZ
- Three Axes
  - X, Y, and Z
- Center
  - Origin - point at the intersection
- Browser

**New Sketch**
- Active sketch

**TECHNICAL NOTES**
Settings specified on the application options and document settings dialog boxes determine orientation of the sketch objects and default sketch plane.
Slide 13

**Sketching, Constraining, and Dimensioning**

**Sketch the Outline of the Part**

- Step 1 - Sketches Overview
  - Sketching strategies, tools, & techniques
    - Outline
    - Draw to finished size/shape
    - Visual Guide – distance & angle
    - No overlaps & gaps
    - Keep it simple
    - Closed vs. Open shape
  - Sketch Tools
    - 34 sketching tools
    - Expert mode on/off

**TECHNICAL NOTES**

Two ways to sketch in Inventor:

1. Use grid snap and coordinates displayed at lower right corner of the graphics window to sketch to precise size.
2. Turn off grid snap and sketch freely without regard to size, then add dimensions later to specify precise size.
Sketch the Outline of the Part

- **Using the Sketch Tools**
  - Visual feedback
- **Line Tool**
  - Powerful tool
  - Endpoint - Arc
- **Inferred Points**
  - Dashed lines
  - Endpoints
    - horizontal
    - vertical
    - perpendicular

Select start of line, drag off endpoint for tangent arc.
Sketch the Outline of the Part

- **Automatic Constraints**
  - Constraint symbols

- **Scrubbing**
  - different constraint applied
  - move the cursor so it touches

- **Precise Input**
  - specified length or angle

- **Selecting Objects**
  - individually objects
  - multiple objects
  - color change

- **Deleting Objects**
  - right-click

**TECHNICAL NOTES**

- **Scrubbing**: Brush the cursor along the line or curve you want to constrain to, then move the cursor into the approximate desired position. In cases where more than one constraint is possible, this technique overrides a default constraint in favor of the constraint you selected.

- **Precise input**: enter exact coordinates for sketch geometry as you sketch.

- **Selecting geometry**: click and drag left to right to select all geometry completely enclosed in the selection window.

- **Click and drag right to left to select geometry enclosed and intersected by the selection window.**
Exercise 2-1

Creating A Sketch With Lines

Constraining the Sketch
**TRAINER NOTE**

Encourage students to view the Learn About Constraints video on the Getting Started screen. Click File>Getting Started>Learn About Constraints.
Constraining the Sketch

- **Geometric Constraints**
  - Adding Constraints
    - Applying
    - Over-constrain
    - Duplicate
  
  “Adding this constraint will over-constrain the sketch”
  - Snap
    - Midpoint, center & intersection
    - Coincident constraint
TECHNICAL NOTES

Constraints are automatically inferred as you sketch. Add only the minimum number of constraints needed to control the sketch shape.

Use Show All Constraints to identify which constraints have been inferred. If you want geometry to have a different constraint, delete the unwanted constraint and reapply a different constraint.
Slide 22

Exercise 2-3

Adding and Displaying Constraints

Slide 23

Sketching, Constraining, and Dimensioning

Adding Dimensions
Adding Dimensions

- **Step 3 – Adding Dimensions**
  - All dimensions created are parametric
  - Control & change size of geometry
  - General Dimensioning
    - Create linear, angle, radial, or diameter
    - Automatically snap
    - Extension lines
    - Preview image
  - Dimensioning Lines
    - Endpoints - two
    - Length
  - Dimensioning an Angle
    - Midpoints of two lines

**TECHNICAL NOTE**

Sketch tab of the Application Options dialog box: select *Edit dimension when created* option to immediately open the edit dimension box. To edit dimensions later, clear the check box.
Slide 25

TECHNICAL NOTE:
Diametric dimensions are created by default if a centerline is included in the dimension. For example, sketch a profile to revolve and change the axis of revolution to a centerline style. When you apply a dimension, the value displayed is the width of the revolved profile.
Adding Dimensions

▶ Entering and Editing a Dimension’s Value
  ▶ Automatically appear
  ▶ Change the value
  ▶ Edit Dimension option
  ▶ Default value
  ▶ To change double-click
  ▶ Enter exact value
  ▶ Accurate to six decimal places
  ▶ Smallest dimensions first

Slide 27

Adding Dimensions

▶ Entering and Editing a Dimension’s Value
  ▶ Repositioning a Dimension
    ▶ New location
    ▶ Origin points cannot be moved
  ▶ Over-Constrained Sketches
    ▶ Inventor will not allow
      ▶ over-constrain
      ▶ duplicate constraints
      ▶ conflict with another constraint
    ▶ Driven dimension
      ▶ Reference dimension
      ▶ Parentheses
      ▶ Over-constrained dimensions option
Exercise 2-4

Dimensioning A Sketch

- Click the Create Dimension tool from the Sketch toolbar, or right-click in the graphics window and choose Create Dimension from the menu.
- Add parametric dimensions to a sketch by clicking the Create Dimension tool from the Sketch toolbar, or right-click in the graphics window and choose Create Dimension from the menu.
- Sketch the outline of the part using the 2D Sketch tools from either the Panel Bar or the toolbar.
- Make a planar face, a work plane, or a non-active sketch in the active part the active sketch.
- Create a new part file by clicking the New icon in What To Do and then clicking the Standard (unit).ipt icon from the Default tab, or click Standard (unit).ipt from one of the other tabs.
- Modify the Part options of Autodesk Inventor by clicking Tools > Application Options and clicking the Part tab.
- Modify the Sketch options of Autodesk Inventor by clicking Tools > Application Options and clicking the Sketch tab.
- Click the Sketch tool from the Standard toolbar then click a face, a work plane, or an existing sketch from the Browser. Or, click a face, a work plane, or an existing sketch from the Browser, and then click the Sketch tool from the Standard toolbar.

Summary

<table>
<thead>
<tr>
<th>To</th>
<th>Do This</th>
<th>Tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify the Sketch options of Autodesk Inventor</td>
<td>Click Tools &gt; Application Options and click the Sketch tab</td>
<td></td>
</tr>
<tr>
<td>Modify the Part options of Autodesk Inventor</td>
<td>Click Tools &gt; Application Options and click the Part tab</td>
<td></td>
</tr>
<tr>
<td>Create a new part file</td>
<td>Click the New icon in What To Do and then click the Standard (unit).ipt icon from the Default tab, or click Standard (unit).ipt from one of the other tabs.</td>
<td></td>
</tr>
<tr>
<td>Make a planar face, a work plane, or a non-active sketch in the active part the active sketch</td>
<td>Click the Sketch tool from the Standard toolbar then click a face, a work plane, or an existing sketch from the Browser. Or, click a face, a work plane, or an existing sketch from the Browser, and then click the Sketch tool from the Standard toolbar.</td>
<td></td>
</tr>
<tr>
<td>Sketch the outline of the part</td>
<td>Use the 2D Sketch tools from either the Panel Bar or the toolbar</td>
<td></td>
</tr>
<tr>
<td>Add geometric constraints to a sketch</td>
<td>Click a constraint from the constraint flyout in the Sketch Panel Bar or Sketch toolbar, or right-click in the graphics window and click Create Constraint and choose the specific constraint from the menu.</td>
<td></td>
</tr>
<tr>
<td>Add parametric dimensions to a sketch</td>
<td>Click the Create Dimension tool from the Sketch toolbar, or right-click in the graphics window and from the menu click Create Dimension or press the hot key D</td>
<td></td>
</tr>
</tbody>
</table>
Applying Your Skills

**Skill Exercise 2-1**

- Create and constrain the profile shown in the following figure.
- Color the edge using the standard SOLIDWORKS color scheme.
- Add dimensions and constraints as shown.

**Skill Exercise 2-2**

- Apply and constrain the profile shown in the following figure.
- Add a key note using the standard SOLIDWORKS note style.
- Add a solid fill and annotate the technique used to create the profile.
- Add geometric and dimensional constraints.

<table>
<thead>
<tr>
<th>Exercise</th>
<th>Applying Your Skills</th>
</tr>
</thead>
<tbody>
<tr>
<td>Locking</td>
<td></td>
</tr>
<tr>
<td>Dimensions</td>
<td></td>
</tr>
<tr>
<td>Constraints</td>
<td></td>
</tr>
</tbody>
</table>

**Exercise**

- Unclip the top edge under the line.
- Insert the top edge.
- Finish the top edge.
- Finish the top edge.
- Finish the top edge.
- Finish the top edge.

**Autodesk Inventor® 6**

[www.autodesk.com](http://www.autodesk.com)
Answers to Checking Your Skills

Use this section to review the answers to the questions at the end of chapter two in the Essentials 6 manual.

1  True___ False___ When sketching, constraints are not applied to the sketch by default.
   False, While sketching, small constraint symbols appear that represent geometric constraint(s) that
   will be applied to the object. If you do not want a constraint to be applied, hold down the Ctrl key
   when the point is selected.

2  True___ False___ When sketching and a point is inferred, a constraint is applied to represent that
   relationship.
   False, When inferred points are selected, no constraints (geometric rules such as horizontal, vertical,
   collinear, etc.) are applied from them. Using inferred points helps create more accurate sketches.

3  True___ False___ A sketch does not need to be fully constrained.
   True, Autodesk Inventor does not force you to fully constrain a sketch. It is recommended
   to fully constrain a sketch, however, as this will allow you to better predict how a part will
   react when dimensions values are changed.

4  True___ False___ When working on an mm part, you cannot use English units.
   False, The default unit for any value can be overridden by entering in the desired unit.

5  True___ False___ After a sketch is fully constrained, a dimension’s value cannot be changed.
   False, To edit a dimension that has already been created, double-click on the value of the dimension
   and enter a new value in the Edit Dimension dialog box.

6  True___ False___ A driven dimension is another name for a parametric dimension.
   False, A driven dimension is a reference dimension. It is not a parametric dimension it just reflects
   the size of the points to which it is dimensioned. A driven dimension will appear with parentheses
   around the dimensions value, like (30).

7  Explain how to draw an arc while still in the Line command.
   While using the line tool move the cursor over an endpoint and a small circle will appear at that
   endpoint. Click on the small circle, and with the left mouse button pressed down, move the cursor in
   the direction that you want the arc to go. Depending upon how you move the mouse, up to eight
   different arcs can be drawn.

8  Explain how to remove a geometric constraint from a sketch.
   Click the Show Constraints tool from the Sketch Panel Bar. Select an object and a row of constraint
   icons will appear, move the cursor over a constraint icon, the objects that are linked to that
   constraint will change color. Then, either click on it and then right-click, or right-click while the
   cursor is over the constraint and select Delete on the menu.

9  Explain how to change a vertical dimension to an aligned dimension while it is being created.
   The technique to change the constraint is called scrubbing. To place a different constraint while
   sketching, move the cursor so it touches (scrubs) the other object to which the constraint should be
   related. Move the cursor back to its original location and the constraint symbol changes to reflect
   the new constraint.

10 Explain how to create a dimension between two quadrants of two arcs.
    - Start the General Dimension tool.
    - Click an arc or circle that includes one of the quadrants to which it will be dimensioned.
    - Move the cursor over the quadrant of the second arc or circle to which it will be dimensioned.
    - Move the cursor over the quadrant until the constraint symbol changes to quadrant.
    - Click and then move the cursor until the dimension is in the correct location, and click.